Why upgrade?

It's becoming even more important to be on the latest version of your software


Aside from all of the amazing new functionality, enhancements and capabilities going into Sybiz solutions every release, there are many other reasons why you should upgrade regularly to the latest version of your software.

Cyber security threats, Microsoft Windows and Server updates, and new government legislation are just a few of the reasons why it's more necessary than ever to keep up to date with the latest in technology. And the financial solutions helping your business operate every day should be a top priority.

Due to a number of technical and legislative changes recently, it is important you read all the information below to see if you are, or will be affected. 

We have regularly communicated these reasons throughout previous years and will continue to do so in the lead up to the relevant deadlines. Make sure you're subscribed to our customer newsletter for regular updates.

 

Single Touch Payroll (Australia only)

Single Touch Payroll is a major reform of payroll reporting standards in Australia and is already mandatory for substantial employers (those who employ 20 or more staff). The second phase roll out of Single Touch Payroll means that smaller employers (those employing 19 or fewer employees) will need to be STP compliant by 1 July 2019 (subject to legislation).

The necessary functionality is only available in Sybiz Visipay version 17.20 and above. There will be some preparation required including data cleansing and formal categorisation of some data in advance.
 

Microsoft Windows XP & Microsoft Windows Server 2003 end of support

Microsoft officially ended security and technical support for Windows XP in 2014 and Windows Server 2003 in 2015. As cyberattacks aimed at businesses of all sizes have become more prevalent and more dangerous - with older operating systems particularly vulnerable - we no longer consider Windows XP and Windows Server 2003 safe operating systems for our business management solutions.

Therefore versions of Sybiz Vision and Sybiz Visipay 17.00 and above are not compatible with Microsoft Windows XP, Windows Server 2003 or older operating systems.

While only a minority of users will be affected by this, it is an important step in securing your business against malicious acts.

 

Microsoft SQL server 2008/2008 R2 compatibility

Microsoft SQL Server is a critical part of what makes Sybiz Vision and Sybiz Visipay such powerful and versatile business management solutions. In version 17.00 and higher, we are utilising the power of Microsoft SQL Server even more to improve the speed and stability of our solutions.

Due to these performance upgrades, Sybiz Vision and Sybiz Visipay version 17.00 and higher will require, at minimum, Microsoft SQL Server 2012.

This means all customers using Microsoft SQL Server 2008 or Microsoft SQL Server 2008 R2 will need to upgrade to at least Microsoft SQL Server 2012 prior to upgrading to the latest versions of Sybiz Vision and Sybiz Visipay. However, we recommend all customers upgrade to SQL Server 2016 for the greatest performance.

Developing innovative accounting, ERP and payroll solutions for 40 years

Connect with Sybiz